Disruption of Service

Incident Report for LINK

Resolved

No further disruptions to the platform have occurred. Will continue to monitor.
Posted Aug 12, 2026 - 17:06 MDT

Monitoring

We have restored service and are monitoring the operation of the site. Next update to follow at 5:00p MT.
Posted Aug 12, 2026 - 16:19 MDT

Investigating

The LINK Workplace Savings Platform is temporarily unavailable. We are taking steps to restore service. The next update will be in 15 minutes.
Posted Aug 12, 2026 - 16:01 MDT
This incident affected: LINK Workplace Savings Platform.